Even with Managed WordPress Hosting, End-Users Must be Proactive About Security

It is rare to go a day without hearing about a vulnerability impacting a certain WordPress plugin or theme. Most recently, vulnerabilities targeting WordPress thumbnailing plugin TimThumb, SEO plugin All in One SEO, and MailPoet, the newsletter plugin with more than 1.7 million downloads, have been exposed, leaving users and their web hosts scrambling to update to patched versions.

Leave a Reply